Skip to main content

Cara Memasang dan Menggunakan Openvpn di Openwrt

Openvpn adalah aplikasi multiplatform sumber terbuka yang sering digunakan untuk mengamankan jaringan internet yang sedang digunakan. Dengan demikian penggunaannya sangatlah penting, manfaatnya agar traffic internet yang digunakan lebih secure (aman) dan private lagi.

Contohnya pada artikel Cara Memasang dan Menggunakan Openvpn di Openwrt yang akan dibahas kali ini, Openwrt adalah sistem operasi pada perangkat tertanam (router) yang memungkinkan penggunanya untuk mengkostumisasi perangkatnya, contohnya seperti memasang Shadowsocks, Openvpn, SSH, dan paket lainnya, yang hal tersebut tidak mungkin dilakukan pada OS bawaan perangkatnya.

Karena secara default paket Openvpn tidak terpasang pada Openwrt, maka kamu perlu memasangnya terlebih dahulu serta kamu juga harus memahami bagaimana cara menggunakan Terminal di Openwrt. Oleh karena itu, sebelum lanjut ke tutorialnya pahami dulu artikel Cara Mengakses Router OpenWRT dari Aplikasi Termux Android atau Cara Mengakses Router Openwrt dengan Putty di PC / Komputer dan Cara Mengakses Router Openwrt dengan WinSCP di PC / Komputer.

Contoh Akun Openvpn dari SSHOcean beserta konfigurasinya

Cara Memasang Openvpn di Openwrt

Sebelum itu pastikan hal-hal berikut ini sebelum memasang Openvpn diperangkat Openwrtnya diantaranya yaitu:
1. Router yang telah tertanam os Openwrt.
2. Koneksi internet.
3. Memori yang cukup (kurang lebih 1MB).
4. Aplikasi Terminal Termux (Android) atau Putty (PC).
5. Akun Openvpn yang masih aktif.

Adapun langkah-langkah pemasangannya yaitu sebagai berikut:
1. Buka Terminal lalu masukan perintah berikut untuk memasang paket Openvpnnya.


opkg update && opkg install openvpn-openssl

Tunggu proses pemasangannya sampai selesai.

2. Setelah itu, masukan perintah berikut untuk mengatur firewall-nya


nano /etc/config/firewall

Maka akan terbuka tampilan baru, selanjutnya masukan perintah berikut di baris paling akhir


config zone
        option name 'openvpn'
        option input  'ACCEPT'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'openvpn tunnel'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option dest 'wan'
        option src 'openvpn'

config forwarding
        option dest 'openvpn'
        option src 'lan'

Untuk berpindah dari satu baris ke baris lainnya gunakan tombol arah / panah yang ada pada aplikasi Termux atau apabila menggunakan komputer gunakan tombol arah yang ada pada keyboard.

Agar konfigurasinya tersimpan, tekan tombol CTRL lalu ketik X, nanti akan muncul konfirmasi Save modified buffer ketik Y, setelah itu akan muncul konfirmasi lagi File Name to Write tekan Enter untuk menyimpannya.

3. Sekarang tinggal mengatur interface-nya, caranya masih sama yaitu dengan memasukan perintah berikut di Terminal


nano /etc/config/network

Maka akan terbuka tampilan baru, lalu masukan perintah berikut di baris paling akhir


config interface 'openvpn'
option proto 'none'
option ifname 'tun0'

config interface 'tunnel'
option proto 'none'
option ifname 'tap0'

Untuk berpindah dari satu baris ke baris lainnya gunakan tombol arah / panah yang ada pada aplikasi Termux atau apabila menggunakan komputer gunakan tombol arah yang ada pada keyboard.

Agar konfigurasinya tersimpan, tekan tombol CTRL lalu ketik X, nanti akan muncul konfirmasi Save modified buffer ketik Y, setelah itu akan muncul konfirmasi lagi File Name to Write tekan Enter untuk menyimpannya.

Cara Menggunakan Openvpn pada Openwrt

Setelah memahami bagaimana Cara Memasang Openvpn pada Openwrt, sekarang tinggal mempelajari bagaimana cara menggunakannya. Adapun langkah-langkahnya yaitu sebagai berikut:

1. Hal pertama yang harus dilakukan ialah membuat berkas password.txt terlebih dahulu, berkas tersebut berfungsi untuk menyimpan username dan password akun Openvpn yang telah kamu buat sebelumnya, dan nantinya akan ditambahkan pada konfigurasi openvpn. Adapun caranya yaitu buka Terminal lalu masukan perintah berikut


nano password.txt

Setelah itu masukan username dan password akun openvpnnya, ketika diterapkan maka hasilnya akan terlihat seperti berikut


sshocean-akunku
vpnku

Agar konfigurasinya tersimpan, tekan tombol CTRL lalu ketik X, nanti akan muncul konfirmasi Save modified buffer ketik Y, setelah itu akan muncul konfirmasi lagi File Name to Write tekan Enter untuk menyimpannya.

2. Setelah pembuatan berkas passwordnya selesai, selanjutnya tinggal membuat konfigurasi Openvpnnya, caranya masih sama yaitu buka Terminal lalu masukan perintah berikut


nano nama_konfigurasi_openvpn

Ketika diterapkan maka hasilnya akan terlihat seperti berikut


nano indonesia.ovpn

Atau bisa juga membuat konfigurasi openvpnnya tanpa memasukan ekstensi ovpn


nano indonesia

3. Maka terbuka tampilan baru, sekarang Salin semua isi konfigurasi Openvpn yang telah kamu buat sebelumnya lalu paste-kan (tempel) salinan konfigurasinya di Terminal / WinSCP.

Tangkapan Layar Aplikasi Termux Android

Tangkapan Layar Aplikasi WinSCP PC

Catatan: untuk menyalin konfigurasi openvpnnya bisa menggunakan teks editor seperti QuickEdit (Android) atau bisa juga dengan Notepad / Notepad++ (PC / Komputer).

Pada bagian auth-user-pass jangan lupa untuk menambahkan password.txt yang telah dibuat sebelumnya dan tambahkan juga


route 0.0.0.0 0.0.0.0 vpn_gateway

Ketika diterapkan maka konfigurasinya akan terlihat seperti berikut


auth-user-pass password.txt
route 0.0.0.0 0.0.0.0 vpn_gateway
client
dev tun
proto udp
remote 103.227.255.176 25000
persist-key
persist-tun
pull
resolv-retry infinite
nobind
user nobody
comp-lzo
remote-cert-tls server
verb 3
mute 2
connect-retry 5 5
connect-retry-max 8080
mute-replay-warnings
redirect-gateway def1
script-security 2
cipher none
auth none

Untuk berpindah dari satu baris ke baris lainnya gunakan tombol arah / panah yang ada pada aplikasi Termux atau apabila menggunakan komputer gunakan tombol arah yang ada pada keyboard.

Simpan konfigurasinya dengan cara tekan tombol CTRL lalu ketik X, nanti akan muncul konfirmasi Save modified buffer ketik Y, setelah itu akan muncul konfirmasi lagi File Name to Write tekan Enter untuk menyimpannya.

Setelah semua konfigurasinya siap, masukan perintah berikut di Terminal untuk menjalankan Openvpnnya


openvpn nama_konfigurasi_openvpn &

Ketika diterapkan maka hasilnya akan terlihat seperti


openvpn indonesia.ovpn &

Apabila Openvpnnya berhasil dijalankan maka akan terlihat seperti gambar berikut

Untuk menghentikan layanan Openvpnnya masukan perintah


killall openvpn

Untuk mengatasi DNS Leak (Kebocoran DNS) yang sering terjadi saat menjalankan VPN pada Openwrt, silakan baca artikel Cara Memasang DNS over HTTPS (DOH) di Openwrt atau Cara Memasang DNSCrypt di Openwrt.

Cara Mengatasi Masalah pada Openvpn

Berikut ini adalah masalah-masalah yang pernah admin temui selama menggunakan Openvpn pada Openwrt beserta solusi penyelesaiannya

1. Ketika menjalankan Openvpn muncul log berikut

Jawabannya: Hal tersebut terjadi karena tanggal pada perangkat Openwrtmu salah, hal itu dapat terlihat dari log yang menunjukan tanggal "Jan 1 07:05:10 2015", oleh karena itu untuk mengatasinya sinkronkan dulu tanggal pada perangkatmu dengan waktu saat ini. Adapun caranya yaitu sebagai berikut:

a. Buka Luci Web Interface dengan cara masuk ke alamat web http://192.168.1.1, pada bagian username dan password masukan kata root.

b. Pilih menu System -> System, pada bagian System Properties -> General Settings lalu tekan tombol SYNC WITH BROWSER, setelah tanggalnya sesuai silakan coba kembali jalankan Openvpnnya.

2. Ketika menjalankan Openvpn muncul log berikut


AUTH: Received control message: AUTH_FAILED

Jawaban: Username dan password akun Openvpn yang kamu gunakan tidak berlaku (Expired) atau bisa juga karena ada kesalahan pada penulisan akun Openvpn yang ada pada berkas password.txt, oleh karena itu cek kembali apakah akun Openvpn yang kamu gunakan sudah Expired atau belum? Apabila kendalanya masih sama silakan cek juga berkas password.txt, kemungkinan ada kesalahan penulisan pada Username dan Password akun Openvpnnya.

Comment Policy: Silahkan tuliskan komentar Anda yang sesuai dengan topik postingan halaman ini. Komentar yang berisi tautan tidak akan ditampilkan sebelum disetujui.
Buka Komentar